HobbyCNC fórum
FTP tárhely: http://cnctar.hobbycnc.hu v0.9.6 Régi HobbyCNC oldal: http://archiv.hobbycnc.hu

Új regisztráció / Átregisztráció a régi fórumról
    
   


UCxxx, mozgásvezérlők MACH3-hoz

Polgárdi Balázs fejlesztései Mach3-hoz.

 

Időrend:
Oldal 5 / 26 Ugrás ide:
Sorok:
|◄ Első  ◄ Előző   1  2  3  4  5  6  7  8  9   Következő ►  Utolsó ►|

  Fórum főoldal  |  A lap aljára

Dr.GodMan | 954    2017-01-31 07:42:00 [1080]

A kék led folyamatosan világít és a plugin könyvtárból mindent töröltem, csak az uc300 pluginját hagytam meg.
Megpróbálom újra beállítgatni a mach3-at, de a legelső gép frissen telepített win7 és frissen letöltött mach3. A második gép egy újrakonfigurált mach3-al van.
Nekem az az érdekes, hogy olyan jelenségek vannak amiket leellenőrizve szoftveres gondra utal. Mert pl sok esetben a bemenő jel megvan csak nincs reakció s mach3 részéről , vagy hirtelen az elmaradt kimenő jelek megtódulnak... A gép teljesítményileg bőven megvan i3 proci 4gb ram, usb-s uc300-al hibátlanul működött a gép de plazmagyújtáskor elszállt az usb kommunikáció és ezt a hibát semmivel sem lehetett kiküszöbölni. Így megpróbálom az ethernetes vezérlőt de ezzel meg ilyen gondok vannak. Keresek a neten egy korábbi mach3-at, hátha... Ha ez sem segít kidobom ezt a sz..t, már az agyamra megy!
Más vezérlőprogramban is gondolkodok, melyiket lehet érdemes megpróbálni plazmavágáshoz ami stabil és megbízható lehet? Hátha más programmal megy...

Előzmény: Polgárdi Balázs, 2017-01-30 20:01:10 [1076]


remrendes | 2174    2017-01-31 01:56:05 [1079]

Aliexpressen jobb velemennyel vannak rola.

Előzmény: ANTAL GÁBOR, 2017-01-30 21:04:17 [1078]


ANTAL GÁBOR | 3917    2017-01-30 21:04:17 [1078]

696 db eladás ( és ebben valószínűleg minden más is benne van és két :" nem működött " bejegyzés . Gyalázat.......

Előzmény: alma999, 2017-01-30 20:09:12 [1077]


alma999 | 170    2017-01-30 20:09:12 [1077]

Hamis UC100

Lent a véleményeket érdemes megnézni.

Előzmény: ANTAL GÁBOR, 2017-01-30 15:38:25 [1072]


Polgárdi Balázs | 452    2017-01-30 20:01:10 [1076]

Amikor a Mach3 fut, az UC300ETH-n a kék led folyamatosan világít, nem villan be néha? Nincs esetleg véletlenül 2db UC300-as dll a Mach3/Plugins könyvtárba? Ha az rendben van, akkor érdemes lenne az xml fájt kitörölni, és újra bekonfigolni, mer néha, ha megsérül az is rejtélyes hibákat tud előidézni. Továbbá, ha a licenc nincs rendben akkor is lehetnek ilyen rejtélyes jelenségek, hogy elindul egyszer csak a másik irányba, illetve megnegálja random a tengelyeken az irányt.

Előzmény: Dr.GodMan, 2017-01-30 19:33:32 [1075]

Dr.GodMan | 954    2017-01-30 19:33:32 [1075]

Üdv!

Ide is bepróbálkozok, hátha valaki tud segíteni...
Van egy olyan problémám, hogy UC300 ethernetes vezérlőt használok és rettenetes kavargós jelenségeket produkál a gép.
Van amikor gondol egyet és a billentyűn az irányító gombokkal irányítva működik rendesen majd gondol egyet és csak az egyik irányba mozdulnak csak a tengelyek. Ilyenkor ha nyomor azt az irányt amerre nem megy, rányomok egy másik tengely irányító billentyűjét és hirtelen megindul nagy gőzzel, mintha a pufferbe maradt volta az adat és kiüríti ami megrekedt...

De van olyan jelenség, hogy a kézzel beírt Gkód-ot nem futtatja le csak klattyan egy rendszerhang, ilyenkor a koordináta kijelző sem megy se a gép tengelye nem mozdul. A külső nyomógombra kivezetékelt pause billentyűt ha megnyomom az MDI fül alatt, utána végrehajtja a beírt kódot.

A sokadig furcsaság, hogy kézzel beírom neki pl G0 y-1000 vagy akár-1 és végállásig kiküldi az adott tengelyt, pedig a 0 pont jó helyen lett felvéve!

De hogy teljes legyen a katasztrófa, van olyan is, hogy elküldöm az adott tengelyt -100 vagy bármilyen negatív pozícióra a 0 ponttól és az entert lenyomva elkezd futni a + irányba... pedig előtte 1-2 perccel még rendesen ment a beírt irányba...

Vagy pl a külső nyomógombra nem állítja be a 0 pontot a Z tengelyen, az x és y tengelyen viszont igen, pedig minden jól van beállítva, a bemenet monitoron is látható a bemenő jel csak nem reagál külső nyomógombra...

Számomra érthetetlen, hogy mi okozhatja ezt, próbáltam másik pc-vel és változatlan! Nem hinném, hogy hardveres lenne!

Valakinek valami ötlet?


CNCdrive | 326    2017-01-30 17:48:49 [1074]

Sziasztok,
Nincsen szó "koppintásról". Egy kínai CNCzone-on hirhedt DDUM ill. Digital Dreams nevezetű mozgásvezérlő gyártó mikrovezérlője van benne.
Azért írtam, hogy hírhedt, mert annyi panasz van rá a CNCzone-on, hogy mára már a gyártó megszüntette a weboldalát is, eltűnt és az ilyenkor szokásos másodlagos feketepiac maradt csak fent utána, amikor névtelen eladók mindenféle online piactereken árulják a termékeiket különféle nevek alatt.
Az UC100 nevet pedig azért írták rá, hátha így eltudják adni, lévén hogy az eredeti UC100 már elég jól ismert a piacon, gondolták, ha ráírják majd jobban fogy és biztos lesz aki nem fog reklamálni ergo profitjuk lesz belőle.

Amúgy a vezérlő mivel nem a mi "kódunk" van benne, hiszen azt azért nem olyan egyszerű szerencsére kilopni, ezért ahogy Balázs írta nem működik a hamisított eszköz a mi szoftvereinkkel, sem az UCCNC-vel, sem a Mach3-as UC100 pluginnal.

Előzmény: guliver83, 2017-01-30 15:42:20 [1073]


guliver83 | 2930    2017-01-30 15:42:20 [1073]

Gondoltam, hogy nem a ti terméketek, de lehetséges hogy a Kínai valamit lekoppintott.

Előzmény: Polgárdi Balázs, 2017-01-30 12:19:40 [1071]


ANTAL GÁBOR | 3917    2017-01-30 15:38:25 [1072]

Én vennék belőle ( helyetekben ) egyet és azután ki kellene próbálni és a negatív tapasztalatokat fel kellene tenni a nyugati közösségi Hobbycnc oldalakra . Az gáz ha mindent sikerült a kínaiaknak leklónozni.
Képesek a dsPic et visszafejteni ?
Itt olvastam hogy amikor cocom listásak voltak az ős processzorok akkor a MEV ben a magyarok csiszolatokat készítettek a ( talán 8080 as prociról és a a végén nekünk is sikerült a klón gyártása )....

Előzmény: Polgárdi Balázs, 2017-01-30 12:19:40 [1071]


Polgárdi Balázs | 452    2017-01-30 12:19:40 [1071]

Ez egy teljesen más termék, semmi közünk hozzá. Csak a mi márkanevünket használja fel, hogy többet eladjon. Aki ilyet vesz, ahhoz támogatást nem tudunk adni, csak a mi általunk gyártott termékekre.

Előzmény: guliver83, 2017-01-30 11:53:24 [1070]


guliver83 | 2930    2017-01-30 11:53:24 [1070]

Szerintem lehetséges.

manapság már mindent hamisítanak.
USBCNC is hamisítják akkor az UC100 miért ne?

Előzmény: istvan58, 2017-01-30 11:42:53 [1069]


istvan58 | 1765    2017-01-30 11:42:53 [1069]

hmmm, és csak kb 13000ft , gyanus ez...

UC100

Előzmény: sanyi84, 2017-01-27 21:11:18 [1067]


dezsoe | 1547    2017-01-28 00:17:07 [1068]

Nézd meg jobban: még csak nem is hasonlít az UC100-ra. :) Két lehetőség van: vagy direkt hamisítvány, vagy csak a keresési találatok miatt van a nevében UC 100.

Az első lehetőség egyértelmű, de akkor a külseje is hasonlítana. Legalább egy kicsit... :)

A második lehetőség olyan, mint amikor bármilyen elektronikai alkatrészt keresel, oda lesz írva, hogy "for Arduino". Függetlenül attól, hogy valaha volt-e már összekötve vele. Ahogy az alkatrész keresgélők buknak az Arduino-s cuccokra, úgy remélik, hogy UC 100-ra keresve megveszed az ő szarjukat.

Előzmény: sanyi84, 2017-01-27 21:11:18 [1067]


sanyi84 | 1135    2017-01-27 21:11:18 [1067]

Az UC 100 at már aliexpressen is áruljátok?


istvan58 | 1765    2017-01-16 10:57:13 [1066]

most láttom hogy az UC400ETH mach3 plugin már az 1.012 verziónál tart.
Nekem még az 1.006 van telepítve. Valahol valami info hogy milyen változások vannak az új verziókba?

CNCdrive | 326    2016-09-15 07:23:06 [1065]

Tegnap írtam választ az UCCNC topikba a #3241.

Előzmény: gorbi, 2016-09-14 16:25:02 [1064]


gorbi | 291    2016-09-14 16:25:02 [1064]

Ha a fehérvári talira elviszem az uc100 vezérlőmet, meg tudod nézni, hogy rendben működik e vagy esetleg én bénázok el valamit és azért nem megy? Régebben beszélgettünk már erről, de sajnos nem sok időm volt foglalkozni vele, ezért elmaradt a pontos diagnózis, félbeszakadt a levelezésünk is.
Jó lenne mert néha használnám ...
Előre is köszi!


istvan58 | 1765    2016-08-20 20:34:00 [1063]

sziasztok,
a feedhold problémát ugy oldotam meg hogy teljes mach3 unistall, majd install, ujra config, azután UC400 telepítés. Most jó. Mindenesetre XML kimentve, hogy ha újra előjön legyen egy jó verzió.

Még valami:
ujra lefutattam a 13000 soros G kódot amit a Béni féle stressz tesztel generáltam. Kód végén 0.02mm eltérés. Ezt jónak itéltem. De aztán újra lefutattam és ugy hogy néha leálítottam véletlenszerüen, 3000, 6000, 8000 környékén, az eredmény +/- 0,03mm eltérés váletlenszerüen, a 0.03mm nálam 30 step impulzust jelent. Na ez igy már nem elfogatható. (mindez Mach3+ UC400)

Majd ugyanez megismételve Mach3 LPT -vel bármikor megálítva mindég abszolút nulára ált az óra.

Na akkor ugyanez UCCNC+ UC400 ....ez is tökéletes!

Ugy hogy mostantól kijelentem : SOHA TÖBBÉ NEM PRÓBÁLKOZOM A MACH3+UC400 KOMBÓVAL. (ha csak Balázsék nem kérnek valamilyen tesztet)
Amúgy ahogy egy fórumtárs is mondta magán levelezésbe (nem nevezem meg :)) hogy ez a mach3+UCxxx amolyan "fából vaskarika" , és úgy néz ki igaza van!

Szóval részemröl a megoldás az hogy mihamarabb váltok UCCNC-re. Addig is amig elkészül a kézikerék és még megoldok néhány konfigot amiben segítséget is fogok kérni Tőletek használom a Mach3-at LPT vel :(.


istvan58 | 1765    2016-08-19 13:38:00 [1062]

Szia Balázs,

kis update a feedhold-al kapcsolatban, légyszi néz be a mach3 topikba a #15346...15348-as bejegyzésekre.

Köszi.


Molnár Szabolcs | 498    2016-08-12 14:50:00 [1061]

Köszönöm a válaszodat.

Előzmény: Gyati, 2016-08-12 09:41:00 [1060]


Gyati | 584    2016-08-12 09:41:00 [1060]

Szia!

Csak USB.

Előzmény: Molnár Szabolcs, 2016-08-12 09:38:00 [1059]


Molnár Szabolcs | 498    2016-08-12 09:38:00 [1059]

SZiasztok. Az UC300 összeköthető a pc paralell (párhuzamos)portjához,vagy csak usb porton keresztül működik?


lovas gyula | 1695    2016-08-08 15:10:00 [1058]

Köszi! Egy kicsit rosszul fogalmaztam.Nem egyhelyben mozog hanem néhány mm határozatlanul az egyik irányba majd vált polaritást miközben egyirányban tekerem a kereket.
A beállitást úgy csináltam ahogy leirtad. LPT-röl igy múködött.
2 gyári tekerővel is próbálom.
Most felrakom az aktuális plug-ot

Előzmény: Polgárdi Balázs, 2016-08-08 11:22:00 [1057]


Polgárdi Balázs | 452    2016-08-08 11:22:00 [1057]

Az MPG-t a "Config" / "Port & Pin" oldalon az "Encoder/MPG's" fülre kattintva lehet beállítani. Az MPG #1-nél pipáld ki az Enable oszlopot, majd állítsd be helyesen a Port és pin bemeneteket.
Ha MPG jogolás közben egy helyben mozog ide oda, akkor nem jól van beállítva valamelyik pinje az MPG-nek.
Ha esetleg jól van beállítva és mégse működik, akkor az aktuális plugin innen tölthető le: UC300 V1_056

Előzmény: lovas gyula, 2016-08-07 21:15:00 [1056]


lovas gyula | 1695    2016-08-07 21:15:00 [1056]

UC 300-Mach3 alatt szeretném az mpg-t beállitani. Párhuzamos porton már hasznátam, de itt nem sikerült. szinte bármit állitok a dro-ban lévő számok csak ugrálnak pozitiv és negativ irányban.
Jó egy éve nem frissitettem az uc300-at.


istvan58 | 1765    2016-08-04 17:14:00 [1055]

na mindegy, szerintem megoldás XML másolat készítése :)

Amúgy lassan csak átállok UCCNC-re :)
Készül a kézikerék. És remélem Ti is megoldjátok a 4. tengely mosgáshatár kijelzését a diag ablakban

Előzmény: n/a (inaktív), 2016-08-04 16:00:00 [1054]


n/a (inaktív) | 1036    2016-08-04 16:00:00 [1054]

István,

Az UC telepítése gyakorlatilag annyiból áll, hogy egy plugin .dll fájlt másol a telepítő a Mach3/Plugins könyvtárába.
Nem tudom ez hogyan tudná a feedhold-ot kikapcsolni ráadásul nyomtató portnál is, szerintem sehogy.

XML hiba miatt pedig ne a feedhold kulcsszóra keresgélj, az túl egyszerű lenne. :)
Az XML meghibásodás annyit tesz, hogy a fájlba például tiltott karakter kerül ami miatt nem tud olvasni bizonyos dolgokat. Vagy például elront zárójelezéseket ami miatt az xml struktúrája elromlik, értelmezhetetlenné válik és megintcsak vagy nem tud bizonyos kulcsokat elolvasni, vagy rossz értékeket olvas.
Az is előfordult már, amit láttam párszor, hogy duplikált belépési pontokat a Mach és utána random jelleggel olvasta ki az értékeket, egyszer innen egyszer onnan.

Előzmény: istvan58, 2016-08-04 15:32:00 [1052]


istvan58 | 1765    2016-08-04 15:33:00 [1053]

mindenesetre ezt az XML-t elmentem és össze fogom hasolítani az újal.

Előzmény: istvan58, 2016-08-04 15:32:00 [1052]


istvan58 | 1765    2016-08-04 15:32:00 [1052]

Balázs,
Nem az UC400-at hibáztatom!
Mivel LPT vel is fennáll a dolog. Ugy tűnik valami bekavart a Mach-nak az UC telepítése után.
És mint látod Fa@ is erre gyanakszik, de neki UC100 után.
Valami lett a mach3 al, de csak gyanakszom hogy az UC telepítés után. De nem azonal. Egy telepítés és új XML jó esélyel segítene de jobb lenne rájönni mi is történhetett. De valószinü tényleg semmi köze csak valami megsérült az XML-ben. Végig néztem de nem látok semmit benne ami esetleg a feedhold ra utal

Előzmény: n/a (inaktív), 2016-08-04 14:46:00 [1050]


n/a (inaktív) | 1036    2016-08-04 15:11:00 [1051]

Közben biztos ami biztos ellenőriztük a feedhold-ot Mach3/UC400ETH-val és nálunk működik gond nélkül.

Előzmény: istvan58, 2016-08-04 10:23:00 [1049]


n/a (inaktív) | 1036    2016-08-04 14:46:00 [1050]

Szia István,

Némi háttérinformáció mielőtt esetleg téves következtetést vonnál le:
Az UC-k nem jegyeznek meg semmilyen Mach3 beállítást, adatot. Minden adat, beállítás futás időben töltődik a mozgásvezérlőbe.
Ebből adódik, hogy nem tud olyat megjegyezni, hogy te például letiltottad a Feddhold-ot.
Ezzel szemben a Mach3 megtud jegyezni bármit, eltud menteni bármit az .xml beállítás fájlba és onnan szed minden beállítást.
A másik dolog, hogy az UC mit sem tud arról, hogy a feedhold tiltva van-e vagy sem. Azt tudja csak, ha egy esemény meghívódik. Például a feedhold. Ha meghívódik akkor az UC végrehajtja, ha nem hívódik meg akkor meg nem.

Amit én gondolok az alapján amiket írtál, hogy egy ideig működött a feedhold, most meg nem működik,
hogy valami megváltozott a beállításokban.
Elképzelhető, hogy a Mach3 .xml fájlja sérült meg, ami sajnos egy jól ismert jelenség Mach3-nál.
Ha a PC úgy kerül leállításra, hogy a Mach3 fut, akkor megtud sérülni a fájl.
Én azt javaslom készíts egy vadonat új xml fájlt és nézd meg azzal megy-e a feedhold.


istvan58 | 1765    2016-08-04 10:23:00 [1049]

Szia Balázs,


megnéznétek a #15307 belyegyzést, és néhányat visszafelé a Mach3 topicban?
Érdekes dolgok merültek fel amit én és fa@ fórumtárs is tapasztalt ami valószínü az UC100 és UC400 al kapcsolatos.



Molnár Szabolcs | 498    2016-07-13 17:45:00 [1048]

Szia!
Összetesteltem mindent mindennel.16mm2=Plazmavágó,cnc váz,vágó asztal,pc szekrény,4mm2=alaplap,uc300,vinyó stb.Most elindul a vágás és el is végez pár műveletet,de randomban most is kifagy pilot gyujtást követően. Gondolom ez a nem megfelelő földelésnek köszönhető. Holnap leverek kettő 2m-es szondát egymástól 20m-re. Remélem ez megoldja a jelenséget. A jelenlegi földszondák már kb 40 éve le van verve.

Előzmény: n/a (inaktív), 2016-07-11 22:04:00 [1041]


Pabló | 1529    2016-07-12 22:16:00 [1047]

Ha fogja tudni az NCT-Fanuc tudását, mi azzal bőven megelégszünk..
Én már hozzá szoktam, mindnek megvan a maga lelkivilága.
Ha kicsit hibázik talán észre se vesszük.

Előzmény: n/a (inaktív), 2016-07-12 21:52:00 [1046]


n/a (inaktív) | 1036    2016-07-12 21:52:00 [1046]

Az, hogy a szerszámkompenzációnak G41/42 hogyan kell működnie azt én úgy láttam, hogy szigorúan definiálva van.
Az oka ennek, pontosan amit írsz, hogy manuális programozáshoz lett ez kitalálva és ott a programozónak pontosan át kell látnia, hogy mi hogyan fog történni. A lényeg annyi, hogy egyetlen mozgás egységgel, szakasszal vagy ívvel néz előre a vezérlés és úgy kalkulál metszéspontot, csatlakozási szöget, eltolt szakaszt, ívet, stb.-t.
Ahhoz hogy minden esetben pontos legyen az eltolt pálya ahhoz viszont olyan távolra előre kéne tekintenie a mozgás kódban a szoftvernek, hogy észrevegye időben, hogy a későbbi kódban már esetleg túlfutott az eltolt és időben előtte álló "jövőbeli" kontúron.
Ez a kézi programozó számára simán átláthatatlanná tehetné a történéseket.
Soronkénti végrehajtásnál tovább bonyolódik a helyzet, na de nem akarok most nagyon belemenni, ha végig gondoljátok akkor szerintem világossá válik.

Majd ha lesz egy kis időm csinálok képernyő képeket egyszerűbb esetlekről némi magyarázattal, amiken jobban látszik és érthető, hogy mi miért történik.

Egyébként már leprogramoztam a G41/G42-t az UCCNC-hez, még finomítások vannak vissza, illesztési dolgok, csak nem akartam még leírni, mert már megtanultam, ha valamit elmondok hogy mindjárt kész és ha mégse készül aztán el időben, akkor jön a számonkérés. :)

A leprogramozás során pedig elég jól sikerült átlátnom az algoritmus problémáit és a korlátokat, ezért is gondoltam hogy ha már megkérdeztétek, akkor felhívom a figyelmet rá, hogy a szerszámkompenzáció az azért nem csodaszer, klassz dolog, de sokszor nem használható büntetlenül.

És egyetértek, hogy esztergákon lehet komolyabban használni a korrekciót, mert a pályák nem olyan bonyolultságúak általában mint egy komplex maró pálya.

Egyébként nem Mach3-at használtam referenciának, hanem többek közt Fanuc és NCT leírásokat ahol definiálják, hogy hogyan működik a vezérléseiken a G41/42 kompenzáció.
De egyébként Mach3-on is ugyanúgy működik, ellenőriztem. :)

Előzmény: Béni, 2016-07-12 21:23:00 [1044]

Pabló | 1529    2016-07-12 21:35:00 [1045]

Szia Balázs!
Ismerem hogy mit jelent pontosan a szerszámsugár kompenzáció.
Cnc-n dolgozok napi szinten, és kézi kódírásnál nagyon nélkülözhetetlen, az természetes, hogy sarkot sose lehet maróval kivágni, de viszont ha más maró, vagy élezett kerül kézbe, nagyon hasznos,hogy beírhatom a sugárt, és figyelembe veszi. Azért sokkal komplikáltabb mindig a programot újra generálni, és mindig keresgetni a rajzfájlt hozzá.
Ipari vezérlők sokszor képesek, hogy ezt már nem bírom megcsinálni, le is tiltok.
Azért azt is át lehet cseszni.

Előzmény: n/a (inaktív), 2016-07-12 00:19:00 [1043]


Béni | 1983    2016-07-12 21:23:00 [1044]

(Nem akarok vitát kezdeni, de ez az egész nagyon sántít.)

A rádiusz kompenzáció lehetősége kézi programozásnál fontos minden olyan technológiánál, ahol szerszámsugár értelmezhető.
Ide értve a láng, plazma, lézervágót és még a huzalszikrát is.
Eszterga esetén viszont nélkülözhetetlen.
Az, hogy a mai világban számtalan CAM rendszer elérhető szinte minden elképzelhető programozási feladatra, nem jelenti azt, hogy ez a funkció értékét vesztette volna. Véletlenül sem a kopás kompenzálására lett kitalálva és alkalmazva.
Bizonyos vezérlőknél a kompenzációs tárban külön van kezelve a kopáskorrekció (Wear).
Programoztam és használtam már néhány ipari vezérlőt, de az említett túlfutással és annak dokumentálásával soha nem találkoztam. (Mach3 nem referencia.)

Fogalmam sincs, hogy milyen algoritmussal és hogyan szokás ezt megoldani. Ha nekem kéne, akkor egy előfordítóval a forrás beolvasásakor elvégezném a párhuzamos "szerkesztését" és nem lenne a végrehajtásban semmi különbség a kompenzálatlan kódhoz képest. (Esetleg a kijelzéshez kellene egy módosított rutin.)

Előzmény: n/a (inaktív), 2016-07-12 00:19:00 [1043]


n/a (inaktív) | 1036    2016-07-12 00:19:00 [1043]

Szia,

Igen, tervezzük, hogy előbb utóbb belekerüljön, bár a szerszámsugár kompenzáció azért sokszor nem optimális megoldás. Arra szokott megfelelő lenni, hogy a szerszám kopást kompenzáljuk mondjuk, vagyis amikor a sugár korrekció nagyságrendileg sokkal kisebb mint a szerszám átmérő,bár ilyenkor is okozhat pontatlanságot a G41/G42 használata, de nagyságrendileg elég kicsit, hogy ne legyen gond.
Ez egyébként azért van, mert a kompenzáció működéséből adódóan nem lesz pontos az eredeti pálya követése, az algoritmus működéséből adódik a pontatlanság. Például ha egy pálya sok kis szakaszból áll és jön mondjuk egy 90 fokos töréspont, akkor a szerszám túl fog futni az eredetitől eltolt pályáról és utólag tud csak visszatérni, vagyis belemar az anyagba ott ahol nem kéne.
Szóval a szerszám sugár kompenzáció hasznossága eléggé limitált és észnél kell lenni, hogy az ember hogyan és mikor használja, a használata nem olyan egyszerű és egyértelmű ahogy első gondolatra tűnik.
CAM programmal újragenerálni a pályát a kompenzált értékkel az jóval pontosabb megbízhatóbb megoldás.

Berakok ide 2 képet Mach3 szerszámkompenzációs képei, a fehér vonal 2mm-el kompenzált pálya.
A második képen kinagyítottam a sarkot, ahol látható, hogy túlfut a pályán.
Ez nem a kompenzációs algoritmus hibája, utánaolvastam több ipari vezérlő adatlapjában is és az algoritmusból adódik, abból ahogyan működik, ahogy működnie kell.
Na szóval a képek:



Előzmény: Pabló, 2016-07-11 22:58:00 [1042]


Pabló | 1529    2016-07-11 22:58:00 [1042]

Akkor ezért nincs a szerszám tárban sugár érték.
Ez valamikor bele fog kerülni?

Előzmény: n/a (inaktív), 2016-07-11 22:04:00 [1041]


n/a (inaktív) | 1036    2016-07-11 22:04:00 [1041]

Sziasztok:

Molnár Szabolcs: Nincs mit, remélem sikerül elhárítanod mihamarabb a problémát.
Azt is megpróbálhatod, ha nem sikerül normális földelést kialakítani, hogy az UC300 felső kis panelkáján van 4 darab d=3.5mm furat, az egyiket egy csavarral és egy minél rövidebb és vastagabb vezetékkel összekötni a számítógép házának egy fémes részével, pl. a ház egy csavarjával.
Ezzel a zaj nem fog ugyan megszűnni, de nagyrészt közös módúvá válik a zaj az UC300 és a PC között, ezzel kevésbé lesz valószínű, hogy problémát okoz.

Pabló: G41/42-t egyelőre nem ismeri az UCCNC, a G43-t azt ismeri.

Előzmény: Molnár Szabolcs, 2016-07-11 21:05:00 [1039]


Pabló | 1529    2016-07-11 21:06:00 [1040]

Szia Balázs.
It az UCCNC-ben hova lehet beírni a szerszám sugár kompenzációt?
Vagy ismeri a progi a g41-g42 kódot?
G43 hossz korrekció kell? Gondolom.

Előzmény: n/a (inaktív), 2016-07-11 19:07:00 [1038]


Molnár Szabolcs | 498    2016-07-11 21:05:00 [1039]

Köszönöm szépen! Elolvastam és érthető a hiba mivolta. Nemrég megnézte két e-on-os ismerős és ők is ezt a hiányosságot állapították meg.(helytelen földelés). Holnap kiépitem és megírom az eredményt. Üdv.


n/a (inaktív) | 1036    2016-07-11 19:07:00 [1038]

Sziasztok,

Molnár Szabolcs: Az UCCNC topikban a #2647 írtam ezzel a problémával kapcsolatban. Többet nem nagyon tudok mondani, ott mindent leírtam.

Gorbi: Akkor az nem .NET probléma biztosan, mert akkor más hibaüzenetet adna, akkor Defective .dll-t írna ki a Mach3.
Légyszi írj egy levelet az info@cncdrive.com e-mail-re a továbbiakról, mert a fórumon lassan fog menni ennek a további tárgyalása, mert nem tudom folyamatosan figyelni a fórumot.

Ftibor: Rákerestem a leveledre és megtaláltam, elnézést, de eddig nem vettem észre. Mindjárt írok választ.


Molnár Szabolcs | 498    2016-07-11 17:39:00 [1037]

Sziasztok. A plazmás topikban leírtam a problémámat. Röviden annyi,hogy mikor a pilot gyújtások kapcsol az uc300 azonnal kifagy. 3 fázisú a plazma vágó. Mi lehet az oka ennek a jelenségnek. A vezérlő egy fém zárható rittal szekrényben van. MAch3 alatt megymenne ) a rendszer. Ha valakinek van valami ötlete és meg is osztja velem azt mélységessen megköszönném.


gorbi | 291    2016-07-11 16:30:00 [1036]

Felugrik egy ablak:
Error!
UC100 not found
Check the connection!

Előzmény: n/a (inaktív), 2016-07-11 10:50:00 [1034]


ftibor | 38    2016-07-11 13:36:00 [1035]

Szia Balázs,

Múlt héte, hétfőn irtam a megrendelésem viszaigozolásával kapcsolatban, de azóta nem kaptam semilyen választ. Kérlek segíts, ha tudsz.
Köszönöm

Fehér Tibor


n/a (inaktív) | 1036    2016-07-11 10:50:00 [1034]

Hibaüzenetet ad a Mach3 induláskor? (Defective dll..)

Előzmény: gorbi, 2016-07-11 00:01:00 [1033]


gorbi | 291    2016-07-11 00:01:00 [1033]

Az 1027-ben leirtaknak megfelel minden, de inditáskor még mindig nem találja az uc-100 -at.
A dot net dolgot ujra lehet telepíteni valahogy?
Melyik részeit takarithatom ki gond nélkül ujra telepítés előtt?

Előzmény: n/a (inaktív), 2016-07-10 23:47:00 [1032]


n/a (inaktív) | 1036    2016-07-10 23:47:00 [1032]

Sziasztok,

Gorbi: Akkor komoly gond nincsen szerintem, azokat nézd/csináld még meg amiket az #1027-ben leírtam.

Pabló: Ezt a letiltást a Mach3 csinálja nem az UC100, illetve akkor tiltja le ha egyszer azt választod indulásnál a Mach3 motion control device selection oldalon, hogy ne mutassa többet az oldalt úgy, hogy a nyomtató portot választod ki. Az UC100 útmutatóba le van írva egyébként meg gondolom a Mach3 adatlapjában is.

Előzmény: Pabló, 2016-07-10 21:03:00 [1031]


Pabló | 1529    2016-07-10 21:03:00 [1031]

Köszi Balázs!
Nekem is ez a Reset device megoldotta a gondot.
Rakhatnátok be erről egy képernyőképet a telepítési útmutatóba. Meg a pdf-et is odarakhatnátok a letöltésbe. Hasznos dolog.

Előzmény: n/a (inaktív), 2016-07-10 18:30:00 [1027]


  Fórum főoldal  |  A lap tetejére

Időrend:
Oldal 5 / 26 Ugrás ide:
Sorok:
|◄ Első  ◄ Előző   1  2  3  4  5  6  7  8  9   Következő ►  Utolsó ►|


 ◊