HobbyCNC fórum
FTP tárhely: http://cnctar.hobbycnc.hu v0.9.6 Régi HobbyCNC oldal: http://archiv.hobbycnc.hu

Új regisztráció / Átregisztráció a régi fórumról
    
   


Épül a gépem ::: GAtesz



 

Időrend:
Oldal 1 / 4   Sorok:
1  2  3  4   Következő ►  Utolsó ►|

  Fórum főoldal  |  A lap aljára

GAtesz | 108    2022-02-07 20:33:24 [186]

Köszi, a tippeket. R28-as a lánc, de a nagyobb távolságot tartok a két rögzített vég között, akkor tudom növelni a rádiuszt. Szerencsére van hely.


Szalai György | 9007    2022-02-06 08:32:38 [185]

A kis hajlítási sugár miatt kis külső átmérőjű vezeték kell. De árnyékolt.
Szükség esetén, a több erű kerek kábelek helyett, adódik a szalag szerkezetű kábelek használata.
Nem profi felhasználásban, pici léptető motornak például a lapos, szilikon szigetelésű USB kábel, vagy a lapos CAT6a kábel.

Előzmény: GAtesz, 2022-02-05 21:26:38 [183]


TBS-TEAM | 1672    2022-02-05 22:05:56 [184]

A probléma a 30mm sugár.

Az energialáncba való kábelek és a robot kábelek is álltalában a kábel átmérőjének 7,5x a minimális hajlítási sugár olyamatos mozgásnál.
Pl:
Ez egy energialáncba való kábel: IGUS CF130.05.04.UL 4x0,5mm2
6mm átm. x 7,5=R45mm a minimális sugár energialáncba.
5.000.000 hajlítási ciklust visel el.
és még nem is árnyékolt, az még növeli az átmérőt.

Ez jó a motorhoz, a R30 sugár viszont ide is kevés.

Pl:IGUS CF10.10.02 4x1mm2 árnyékolt. Ultra hajlékony.
8mm átm. x 5 = R40mm a minimális sugár energialáncba.
5.000.000 ciklus, ha már R48 akkor 7.500.000 ciklus,
ha R64 10.000.000 ciklus

Előzmény: GAtesz, 2022-02-05 21:26:38 [183]


GAtesz | 108    2022-02-05 21:26:38 [183]

Köszönöm. Beszerzem.
És a motorokhoz milyen vezetéket kellene használnom? Gondolom a minél több elemi szálból álló a jobb. Keresgettem, de nem nagyon találtam. 3A-osak a motorok. És szeretnék egy 2KW-os főorsót.


Szalai György | 9007    2022-02-04 05:30:33 [182]

A szilikon vastag falú vákuumcsövet.

Előzmény: GAtesz, 2022-02-03 20:03:39 [180]

TBS-TEAM | 1672    2022-02-03 21:33:02 [181]

Poliuretán (PU SH A98) cső 6mm-es min:20mm sugárban hajlítható

Előzmény: GAtesz, 2022-02-03 20:03:39 [180]


GAtesz | 108    2022-02-03 20:03:39 [180]

Milyen csövet érdemes a 30mm sugarú energialáncba betenni, a főorsó hűtővíz elvezetésére, ami nem törik hamar a sok mozgástól? Van valami bevált márka erre? A "hagyományos" benzincső gondolom nem jó választás. Kb 6mm-es cső kellene.


A_Camera | 879    2020-07-08 17:49:37 [176]

Akkor örülök hogy megoldottad, de bocs, mert a beszólásom fölösleges volt... De ha a maximum sebességet ki akarod próbálni akkor azzal a G1 kóddal kell.

Előzmény: GAtesz, 2020-04-20 07:23:38 [168]


A_Camera | 879    2020-07-08 17:45:44 [175]

Ezzel a kóddal próbáld ki. G0 az mindig max sebességgel megy, G1 segítségével pedig tudod megszabni a maximumot. Kezd ezzel, ha utána jó akkor növeld F1000 ről magasabbra, ha itt is hiba lesz akkor pedig csökkentsd F500 ra és újra próbáld.

F1000
G1 Z10
G1 Z20
G1 Z10
G1 Z20
G1 Z10
G1 Z20
G1 Z10
G1 Z20
G1 Z10
G1 Z20
G1 Z10
G1 Z20
G1 Z10
G1 Z20
G1 Z10
G1 Z20
G1 Z10
G1 Z20
G1 Z10
G1 Z20

G1 Z0
M30

Előzmény: GAtesz, 2020-04-19 10:24:27 [152]


GAtesz | 108    2020-05-05 10:37:19 [174]

Köszi. A tied is patent!

Előzmény: izbeki, 2020-05-04 09:47:18 [170]


őrülT-Tudós | 129    2020-05-04 12:36:47 [173]

Üdv, Jól néz ki! Beszállok én is, nálam is pont aktuális a téma!

  

Előzmény: GAtesz, 2020-05-04 08:49:23 [169]


GAtesz | 108    2020-05-04 12:23:03 [172]

Sima mélyhornyú golyóscsapágyas. Nem mértem még a kottyanását. Még fel kell szabályozni a tokmány illesztő peremét. Pluszosra készült.

Előzmény: elektron, 2020-05-04 10:41:33 [171]


elektron | 15859    2020-05-04 10:41:33 [171]

Belül hogy néz ki ? Kottyanás mennyi ?

Előzmény: GAtesz, 2020-05-04 08:49:23 [169]


izbeki | 1065    2020-05-04 09:47:18 [170]

Gratula, szuper lett!
Azért kimentem a műhelybe, hogy az enyém megvan-e még!

  

Előzmény: GAtesz, 2020-05-04 08:49:23 [169]


GAtesz | 108    2020-05-04 08:49:23 [169]

Újabb alkatrész készült a gépemhez. Még a motortartó lemezt kell megcsinálni hozzá.

  

GAtesz | 108    2020-04-20 07:23:38 [168]

Sikerült megoldani a problémát!

A kernel frekvenciát visszavettem 25000 Hz-re és jó lett.
Aztán vissza tettem 35000 Hz-re, valamint a motor tuning lapon lehet állítani a step és dir pulse hosszát. Megtévesztően 0-5 érték van fölé írva a beviteli mezőnek. De megenged nagyobb értéket is. Beírtam 15 -öt (us) és így is jó. Az este még tesztelgettem, és gyönyörűen mindig visszaáll a nullpontra század pontosan mind a három tengely.
Örülünk!
Köszönöm mindenkinek aki segített!
Üdv, Atesz


elektron | 15859    2020-04-19 17:49:13 [167]

Nem lesz itt nagy gond, ahogy a többiek is mondják a dir jel nem ér oda időben ezek miatt az irányváltásoknál, akár több ok is lehet egyszerre, ha 0 a step dir hossza, meg még az LPT kártya is szar, meg még az optó is stb. ... úgyhogy mindnek jónak kell lenni, amit egyébként nem nehéz elérni.

Előzmény: GAtesz, 2020-04-19 10:33:34 [153]


Törölt felhasználó    2020-04-19 15:39:03 [166]

Bocsanat a rossz linkert, köszönöm az észrevételt. Termeszetesen az eredeti uc100 ra gondoltam. Visszont ebbol is látszik , hogy nem véletlen másolják. Melleseg ha figyelembe vesszük a tudását és a minőséget nagyon kedvező árfekvesben vannak a gyartonal ezek cél hardverek

Előzmény: dezsoe, 2020-04-19 15:20:53 [164]


dezsoe | 2633    2020-04-19 15:26:35 [165]

Pontosan ez a teszt mutatja meg, hogy mi a hiba: az irányváltásoknál nem jókor veszi figyelembe a dir jelet. Gondolom, hogy ahány irányváltás, annyiszor egy lépésnyi távolságot téved. A step polaritását kizártad. A kernel sebességet lefelé kéne vinned, nem felfelé. Az LPT portra olyan illesztőt próbálj meg, amelyik tartalmaz valamilyen jelerősítést. (Általában 74xx244 vagy 74xx245 IC van rajta.) Nem lehet kizárni, hogy egyik irányba gyorsan vált a kimenet, míg a másikba lassabban, ami terhelés hatására még romolhat, ezt tudod kicsit kompenzálni az erősítéssel.

Előzmény: GAtesz, 2020-04-19 08:48:50 [147]


dezsoe | 2633    2020-04-19 15:20:53 [164]

Úgy általában igazad van, de az a szemét, amit odalinkeltél, az egy kínai hamisítvány, amit egyáltalán nem kéne reklámozni. Az UC100 magyar gyártmány és érdemes a gyártótól venni.

Előzmény: Törölt felhasználó, 2020-04-19 15:11:59 [163]


Törölt felhasználó    2020-04-19 15:11:59 [163]

Én is végig játszottam hasonlót , biztos van olyan lpt tipus ami bevált de szerintem nem erre való , volt h napokig hibátlanul ment aztán hibázott minden felét minden apróság bezavarhatja, mondjuk tanulni jo:). A kiadott jelek olyanok amilyenek. Uj gépet kapsz, egy Dsp -s ( leadshine -tol eleg barati aron vannak es nagyon jok) meghajtó és külső vezérlő minden pénzt megér.

Én egy uc300eth hasznalok szerintem nagyon profi cucc.
Itt neha latni 30eft kornyeken de uc100 mar egesz olcson kaphato.

https://www.ebay.co.uk/itm/252592345367

Előzmény: GAtesz, 2020-04-19 14:14:24 [160]


Arany János | 1193    2020-04-19 14:43:09 [162]

Lehet, hogy hülyeség!
De esetleg MDI-ben egy G92.1, hátha bekerült egy eltolás valamikor.

Előzmény: GAtesz, 2020-04-19 14:14:24 [160]


remrendes | 3512    2020-04-19 14:19:58 [161]

Én kipróbálnám LinuxCNC-vel.

Előzmény: GAtesz, 2020-04-19 14:14:24 [160]


GAtesz | 108    2020-04-19 14:14:24 [160]

Jól hangzik amit mondasz de az megint egy csomó pénz. Nem hiszem el, hogy nincs erre a hibára megoldás. Szerintem sokan használják LPT vel a gépüket hiba nélkül. Ha elfogytak az ötletek, és a hiba fenn áll, akkor továbblépek.

Előzmény: Törölt felhasználó, 2020-04-19 12:04:18 [156]


GAtesz | 108    2020-04-19 14:09:59 [159]

Nem jött be. Most készül egy másik asztali gép konfig.

Előzmény: tomtoled, 2020-04-19 09:06:10 [148]


GAtesz | 108    2020-04-19 12:13:42 [158]

Ezt még kipróbálom, köszi.

Előzmény: tomtoled, 2020-04-19 09:06:10 [148]


GAtesz | 108    2020-04-19 12:12:43 [157]

Nem segített. A kernel sebességet feltettem 100KHz re az sem segít. Van itthon egy másik LPT Boardom, lehet, hogy átcserélem. Meg van itthon másik LPT-s régi alaplapom a szekrényben. Lehet, hogy dobok össze egy gépet belőle szűz XP vel.

Előzmény: svejk, 2020-04-19 11:24:16 [155]


Törölt felhasználó    2020-04-19 12:04:18 [156]

Szia!
LPT -rol hajtod ? Tipikusan tud ilyen hibakat okozni, csak kinlodas ha valtasz egy rendes mozgasvezerlore pl uccnc re vagy hasonlora ugyan az a masina joval nagyobb sebessegre lesz kepes ugy hogy soha nem hibazik. Az LPT borzaszto kaotikus 1000x gyarto es driver nehany jo a tobbi csak szivas.

Előzmény: GAtesz, 2020-04-19 08:48:50 [147]


svejk | 31464    2020-04-19 11:24:16 [155]

Léptetősvezérlőnél a step pulse és dir pulse értékét állítsd minimum 2-re de inkább 5-re.

Előzmény: GAtesz, 2020-04-19 10:33:34 [153]


Levin | 71    2020-04-19 11:16:44 [154]

Szia
Én még amit megnénék
Mach3 Kernel frekijét.Az is tud ilyen turpisságot okozni
Illteve nem tudom összefüggében lehet -e de Backlash nincs -e bekapcsolva illteve ha be van ott milyen érték van.
Levente

    

Előzmény: GAtesz, 2020-04-19 10:33:34 [153]


GAtesz | 108    2020-04-19 10:33:34 [153]

Mach3

    


GAtesz | 108    2020-04-19 10:24:27 [152]

G0 Z10
G0 Z20
G0 Z10
G0 Z20
G0 Z10
G0 Z20
G0 Z10
G0 Z20
G0 Z10
G0 Z20
G0 Z10
G0 Z20
G0 Z10
G0 Z20
G0 Z10
G0 Z20
G0 Z10
G0 Z20
G0 Z10
G0 Z20

F700
G1 Z0
M30


elektron | 15859    2020-04-19 09:43:21 [151]

Ez alapján pedig úgy néz ki, az a bajod, hogy minden léptetési g kód ciklus után lehet az irányváltásnál egyet téved, ez arra utal, hogy az irány DIR jeled és a STEP jel közt nincs elég ideje átváltódni, és magyarán minden irányváltáskor egy hiba adódik a pozíciódhoz, ezért kérdeztem, miylen szoftverrel hajtod és az hogy van beállítva a configja, meg ami dezsoe is kérdezett, ha a jel nem jó polaritzású is okozhat ilyet.

Mach3-ban pl. a DIR jel meg a STEP jel közti idő hosszát vagy a DIR hosszát kell nagyra állítani, mert ha olyan kicsi, hogy az optocsatolón nem megy át olyan hamar, mint kéne, akkor az első lépésnél még a régi állapot szerint lép, rossz irányba.


elektron | 15859    2020-04-19 09:17:29 [150]

A mozgató kód az hogy néz ki ?

Előzmény: elektron, 2020-04-19 09:14:48 [149]


elektron | 15859    2020-04-19 09:14:48 [149]

Ezek jó tesztek voltak kizártunk pár dolgot így.

Milyen szoftverrel hajtod ?

Előzmény: GAtesz, 2020-04-19 08:48:50 [147]

tomtoled | 411    2020-04-19 09:06:10 [148]

Nálam is volt ilyen jelenség, esetemben a motorvezérlő áram csökkentése megoldotta a problémát(10%), de próbáld meg mindkét esetet.(csökkentés--növelés).
Sok sikert

Előzmény: GAtesz, 2020-04-19 08:48:50 [147]


GAtesz | 108    2020-04-19 08:48:50 [147]

Csináltam még több tesztet.
-Megfordítottam a motor egyik tekercsének a két vezetékét (nyilván fordított lett a mozgás irány) és a hiba ezután nem lefelé keletkezett, hanem felfelé. (tehát nem a súly/terhelés okozta hiba)
- Ha növelem a mozgás hosszát, (10mm-ről 50mm-re)és az ismétlés szám változatlan a hiba ugyan annyi.
- Ha növelem az ismétlésszámot, a hiba arányosan növekszik. (dupla ismétlés, dupla méretű hiba)
- A hiba méretét nem befolyásolja a mozgás sebessége.


GAtesz | 108    2020-04-19 08:41:34 [146]

Nem vált be. Ugyan az.

Előzmény: dezsoe, 2020-04-18 23:57:17 [145]


dezsoe | 2633    2020-04-18 23:57:17 [145]

Fordítsd meg a step jel polaritását (active low).

Előzmény: GAtesz, 2020-04-18 21:54:47 [144]


GAtesz | 108    2020-04-18 21:54:47 [144]

Köszönöm, sok munka van bent, ez az első gépem, teli hibákkal.

Z tengely tesz. Csináltam csomó tesztet és mindig ugyan az az eredmény.

10mm fel-le 10x a hiba 0.055mm
10mm fel-le 20x a hiba 0.11mm

Csináltam két tesztet különböző beállításokkal:
Sebesség: 1000mm/min gyorsulás: 50mm/min
Sebesség: 6500mm/min gyorsulás: 600mm/min
Ugyan az az eredmény.

Kicseréltem a tápot egy teljesen más fajta tápra, ugyan az az eredmény.

Kicseréltem a motorvezérlőt, ugyan az az eredmény.

Teszt1
Teszt2

Előzmény: elektron, 2020-04-18 19:44:35 [143]


elektron | 15859    2020-04-18 19:44:35 [143]

Azt látom a mechanika szépen össze van rakva, meg az elektronika is, a videódon amit látok belőle egyébként, mindenképpen dícséretet érdemel.


elektron | 15859    2020-04-18 19:42:41 [142]

Ha csak két tengely mozgatsz, pl. az X, Y-t, akkor nem izeg mozog meg néha picit a Z is ? Illetve ugyanígy a többui kombinációban, ha zavarja valami elektromosan sőt mozgatni sem kell, akkor is csinálhat ilyet.

Előzmény: GAtesz, 2020-04-18 19:10:02 [140]


elektron | 15859    2020-04-18 19:41:06 [141]

Akkor van ott baj rendesen.

A G kódtól a motor tekercséig tartó szoftverikus és elektromos elekláncolatban, illetve a motor kimenő tengelyétől a mozgatott részekig való mechnaikus kapcsolatokban valahol nem fix valami.

- motorok tápja elégséges ?
- vezetékek mind stabilan csatlakoznak ?
- jelvezetékeket nem zavarja nagyáramú táp vagy motor vezeték ?
- nem csúszik me semelyik kerék a tengelyén ?
- a meghajtó szoftver step jel és dir jel kimenete elégséges széles impulzust ad ki és jól időzítve ?
- gyorsulás és sebesség értékek biztos nem túl nagyok még mindig ?
- mechanika nem szorul bizonyos helyeken akár az orsó akár a lineárok ?
- stb. van itt kérdés nem egy

Előzmény: GAtesz, 2020-04-18 19:10:02 [140]


GAtesz | 108    2020-04-18 19:10:02 [140]

Vissza vettem több lépcsőben az értékeket, de érdekes mód, a hiba mindig kb ugyan annyi. 7mm-rel lejjebb kerül a program végére. Most a Z tengely paraméterei: Sebesség: 1900mm/min gyorsulás 90.
De az X és az Y is téveszt. Az most vettem észre.


elektron | 15859    2020-04-18 15:56:47 [139]

Jelenleg mennyi a sebesség, és a gyorsulás illetve milyen szoftverrel hajtod ?

Lehet, mikor felfele hirtelen megindul, akkor téveszt, mivel felfele nagyobb erő kell neki, és ezért aztán lejjebb kerül a nullpontja.

Előzmény: GAtesz, 2020-04-18 15:33:33 [138]


GAtesz | 108    2020-04-18 15:33:33 [138]

Kitörő örömmel jelentem, hogy újra mozog a gépem. Ma csináltam vele az első marást. Elkészült de nem volt egyszerű menet. A Z tengelyem folyamatosan téveszt. A marás végére 10mm-rel mélyebben mart mint az elején. Hogyan tudnám kiküszöbölni ezt a hibát? Csökkentsem tovább a tengely sebességét a setup- ban?

          


TBS-TEAM | 1672    2020-01-12 19:48:36 [137]

Ez nem CNC vagy nem CNC függő ez mechanika kialakítás súly és az elérni kívánt sebesség.
Ahhoz a kis géphez még a 1204 is bőven elég még sok is.

Előzmény: A_Camera, 2020-01-12 18:00:38 [136]


A_Camera | 879    2020-01-12 18:00:38 [136]

Szerintem CNC-hez legalább 1605 kell. Nekem 1204 a 3D printeren van, a CNC-n 1605.

Előzmény: GAtesz, 2020-01-10 17:54:19 [134]


TBS-TEAM | 1672    2020-01-10 18:13:23 [135]

Nézd meg a csapágy tartók méreteit és amelyik belefér a mechanikádba azt rendeld meg.
Vagy ahol a legkisebb áttalakítás kell.

Előzmény: GAtesz, 2020-01-10 17:54:19 [134]


GAtesz | 108    2020-01-10 17:54:19 [134]

Oké, köszönöm.
Elég lehet az én gépemre egy 1204 es méret, vagy vegyek 1605-öt?

Előzmény: TBS-TEAM, 2020-01-10 17:27:24 [133]


  Fórum főoldal  |  A lap tetejére

Időrend:
Oldal 1 / 4   Sorok:
1  2  3  4   Következő ►  Utolsó ►|


 ◊