HobbyCNC fórum
FTP tárhely: http://cnctar.hobbycnc.hu v0.9.6 Régi HobbyCNC oldal: http://archiv.hobbycnc.hu

Új regisztráció / Átregisztráció a régi fórumról
    
   


Mach3 CNC vezérlő program

Mach3 CNC vezérlő szoftver használata...

 

Időrend:
Oldal 2 / 348 Ugrás ide:
Sorok:
|◄ Első  ◄ Előző   1  2  3  4  5  6   Következő ►  Utolsó ►|

  Fórum főoldal  |  A lap aljára

farkastibor | 457    2019-06-22 21:08:03 [17455]

MinMax G-code free progihttp://www.intuwiz.com/progs/minmax-g-code.html#.XQ57F-v7Spo

  

Előzmény: Robsy, 2019-06-21 14:27:48 [17453]


zotykó | 293    2019-06-21 21:53:58 [17454]

Kössz.
A G kód ok volt. A jelhosszúság állítása jó ötlet, bár eddig évekig nem okozott ez gondot. Majd ha gép előtt leszek csinálok pár tesztet.
Lehet a vezérlőm puffer kondijai ereszkednek meg a tápban? Az is okozhat fesz ingadozást.

Előzmény: Robsy, 2019-06-21 14:27:48 [17453]


Robsy | 1034    2019-06-21 14:27:48 [17453]

A Mach3 egyik hibája, hogy a step jelek csak néhány us szélességűek függetlenül a léptetési frekitől, és ez sajnos a lépésvesztés egyik fő oka lehet.
Próbáld meg a motortuning-ban maximumra állítani step és dir pulse with értékét.

A G kód lejátszáskor figyeld meg a Z koordinátád adatát, ha ott nincs ciklusonként elcsúszó adat, akkor a jó a G kódod.
Vannak CNC szimulátor programok is (magamnak is csináltam egyet), amibe beküldheted a G kódot, és ellenőrzi a programozott elmozdulások helyességét.

Előzmény: zotykó, 2019-06-21 13:37:16 [17452]


zotykó | 293    2019-06-21 13:37:16 [17452]

Hello.
Mach 3-nál találkoztatok olyan hibával, hogy egy nagy és részlet teli anyagot gravírozva mindig egyre lejjebb ment a maró? Elkezdtem gravírozni egy nagy táblából ruhatári bilétákat, sokat, és a kb. 20-adik karakternél észrevettem, hogy lejjebb megy a maró. Mindig kicsit lejjebb. A -0.3mm mélységből a mondjuk 40-edik karakternél már -0.97mm volt.
Hogy mi??
Aztán a motor tuningnál lejjebb vettem a gyorsulásokat és a végsebességeket, de mind hiába.

Amikor a kereteket marom, azoknál nincs baj. Pedig az is van 40 "Z" irányú pozicionálás.

Pont ez miatt gyanakszok inkább valamire a programban mint a mechanikában. Van-e ilyen gyík vele?

A gépem Évek óta jól működött, tehát nem valami építési hiba lehet. A motorok 2NM-es léptetőmotorok és Nanotec gyári vezérlőkkel hajtom.
Olyan mint ha a "Z" tengely amikor fölfelé indul, akkor lépést vesztene néha.

Megtörhetett a motor kábele???? Akkor nem kéne többet hibáznia és mindkét irányban??

Esetleg még a kernell sebességet megpróbáljam lejjebb venni?

Vagy valami ötlet?? Minden tapasztalat érdekel.

Kössz előre is.


Robsy | 1034    2019-06-21 12:13:22 [17451]

A földelésről egy szót sem ejtettem.
De ha már felhoztad a marómotorod tengelye és a szerszámbefogó része hogyan van földelve? Ha meg kerámia csapágyas, de pláne áll a kérdés?

"A hobbista bontott kopott vezetőket használ."
A nehézségi gyorsulás, szerelési pontatlansági és a gyenge gép merevségből adódó deformációs/befeszülési hibák a hobbysta gépére is mindig hatnak (ráadásul egynél több kocsi szokott lenni), így az állandó szigetelés fém konstrukciójú kocsiknál kizárt, ez volt csak szösszenetem lényege, kár ezen többet rugózni, főleg nem egy Mach3 topikban.

Előzmény: D.Laci, 2019-06-21 08:05:32 [17450]

D.Laci | 4485    2019-06-21 08:05:32 [17450]

A műanyag betétes lineáris vezetőkkel mi a helyzet, hogyan kel földelni?
Az előfeszített kocsik példája is csak egy ideális állapot, előbb vagy utóbb megkopik. A hobbisat bontott kopott vezetőket használ.

Előzmény: Robsy, 2019-06-20 21:04:32 [17448]


TBS-TEAM | 68    2019-06-20 21:22:41 [17449]

Ez csak egy példa az oljafilm erejéről.

Egy pár ohm-Kohm is több mint megengedhető.

Minden barkácsolónak szive joga szopni a jól bevált megoldások nem alkalmazásával.

Előzmény: Robsy, 2019-06-20 21:04:32 [17448]


Robsy | 1034    2019-06-20 21:04:32 [17448]

Totál rossz példát hoztál ide.
A hézaggal szerelt siklócsapágyak nagy felületű hidrosztatikus viszonyai egészen mások, mint amikor egy nagy keménységű golyó gördül ugyancsak nagy keménységű minimális felfekvő felületeken előfeszített viszonyok közepette.

Egyébként meg javaslok neked egy tanulságos oszcilloszkópos mérést (ezt véletlenül én már kb. 10 évvel ezelőtt megtettem), amikor kiméred, hogyan is alakul egy lineáris golyós kocsi/sín villamos ellenállás "zaja" különböző terhelések, előfeszítések, és mozgási sebességek kapcsán. Hidd el távol van a Mega ohmos szigetelő esetétől, amit te írtál, ezért pontosítottam, korrigáltam az állításodat a valós tények tükrében.

Előzmény: TBS-TEAM, 2019-06-20 20:05:11 [17447]


TBS-TEAM | 68    2019-06-20 20:05:11 [17447]

Egy kis érdekesség

1987 Kandó kálmán egyetem. Bemutatót tarottak a Ganz Mávag egyik üzemében 80T mozdony 4 tengely= 8db siklócsapágy.
Tengelyenként 10Tonna nyomás.
Felfekvő felület 90mmx280-300mm / csapágy.
Olaj kenés (mechanikus egy fém lapát a tengely végén a forgás következtébe belemerül az oljba és azt felhordja egy oljvezető vájuba, onnan az olaj gravitációval rácsorog a tengejre, ami beviszi a siklócsapágyhoz) sose romlik el megoldás.
5 Km/óra sebességnél már kialakult az olajfilm.
Elemelkedett a csapágy a tengelytől.
A V43 villanymozdonyok a mai napig siklócsapágyakkal üzemelnek.

Annak idején az én tanáraim kisérletekkel be is mutatták az elméletben tanítottakat.


Akkor az lehet mágia volt vagy szemfényvesztés az a sok minden amit tanultam.

Előzmény: Robsy, 2019-06-20 07:42:55 [17445]


lovas gyula | 1736    2019-06-20 08:14:06 [17446]

Szia Tibor!
Ennek ellenére a korrekt megoldás ha mindez át van hidalva egy földelő vezetékkel

Előzmény: Robsy, 2019-06-20 07:42:55 [17445]


Robsy | 1034    2019-06-20 07:42:55 [17445]

".. SZIGETEL mozgás közben."
Ez szerintem megint egy hibás, pongyola állítás.
Elfeledkeztél arról, hogy egy beépített kocsinak van terhelése, és a kocsi már eleve előfeszített is lehet.
Ennek következtében mozgáskor a folyamatos szigetelés kizárt, de még a csak néhány mikroszekundumig tartó 100 kOhm feletti átmeneti ellenállás se nagyon mérhető ki mozgás közben.

Előzmény: TBS-TEAM, 2019-06-19 21:55:08 [17443]


Windrad | 194    2019-06-19 22:37:37 [17444]

D Lacinak már megadtam a választ Ugyan ezt tudom mondani neked is

Előzmény: TBS-TEAM, 2019-06-19 21:55:08 [17443]


TBS-TEAM | 68    2019-06-19 21:55:08 [17443]

(A lineáris tengelyek nagyon sok csavarkötéssel csatlakoznak a gépvázhoz ,ami a vezérlő dobozzal együtt fém szerkezet. Szerintem ez a kapcsolódás a csavarokon keresztül biztosítja azt hogy közös potenciálon legyenek.)

A lineális tengelyek és sinekkel nincs is gond mert azok nagy felületen érintkeznek ahhoz a géptesthez melyhez csavaroztad, VISZONT a tengelyek közötti mozgást csapágygolyók biztosítják melyek minimális felületen érintkeznek tized-százaezred mm2 az össz érintkezési felület és még zsír vagy olajfilm is van közöttük GÖRÜLÉS KÖZBEN mely SZIGETEL mozgás közben. Álló helyzetben viszonylag kis ohmikus elleneállás mérhető de mozgás közben akár megaohmok.

A külön mozgó egységeket mindig közös potenciálra kell hozni.

Előzmény: Windrad, 2019-06-18 21:16:43 [17438]


Windrad | 194    2019-06-19 11:54:04 [17442]

Sajnos nincs szkóp a közelemben amivel ezt megmérhetném

Előzmény: lazi, 2019-06-19 08:31:22 [17440]


Windrad | 194    2019-06-19 11:52:50 [17441]

Ebben teljesen igazad van, viszont mint írtam ez éreintésvédelem szempontjából fontos de a zavarszűréssel nincs összefüggésben. Szerintem.. de lehet hogy tévedek..

Előzmény: D.Laci, 2019-06-19 08:23:39 [17439]

lazi | 1477    2019-06-19 08:31:22 [17440]

Apróságnak tűnik, de érdemes megnézni az elektronikát is, ha a való világban lassú a papír szerint megfelelő sebességű optocsatoló, az is tud érdekes ellépéseket okozni. Szkóp, és nézd meg, hogy az 1-5 us beállítása után milyen jelformátum megy tovább.

Előzmény: Windrad, 2019-06-14 21:12:02 [17420]


D.Laci | 4485    2019-06-19 08:23:39 [17439]

"A lineáris tengelyek nagyon sok csavarkötéssel csatlakoznak a gépvázhoz"

Gondolom a lineáris tégelyekben golyók vannak. Na azok nem igazán tekinthetőek fémes kapcsolatnak. Ezért kel külön minden mozgó részt "földelni".

Előzmény: Windrad, 2019-06-18 21:16:43 [17438]


Windrad | 194    2019-06-18 21:16:43 [17438]

A lineáris tengelyek nagyon sok csavarkötéssel csatlakoznak a gépvázhoz ,ami a vezérlő dobozzal együtt fém szerkezet. Szerintem ez a kapcsolódás a csavarokon keresztül biztosítja azt hogy közös potenciálon legyenek. Ennek jelentőségét áramütés szempontjából látom fontosnak, mivel a nagyfeszültségű hálózat földelése is ehez csatlakozik. Lehet hogy rosszul mondom de majd a többiek cáfolják vagy megerősítik. Ha te a vezérlő elektronikájára gondolsz és a zavarszűrés szempontjából kérdezed akkor ennek nincs jelentősége mivel se a motorok DC tápegysége ,se a vezérlő DC áramellátásának negativ pólusa (GND)nem csatlakozhat a gépvázhoz, mivel így az árnyékolt vezetékek funkciója elveszik földhurok keletkezik De lehet hogy nem értem a kérdésedet...

Előzmény: tibs, 2019-06-18 12:15:18 [17437]


tibs | 118    2019-06-18 12:15:18 [17437]

A gépvázra gondolok. A z tengely lapját az y tengely lapjával és az x tengely lapjával és azt a földre. A lineáris sin az nem tökéletes kontakt föleg ha rezgések vannak. Egy pár embernek már megoldotta a misztikus problémáját ez az apró fogás. Én porszívót kapcsolgatok, másik gépen esztergálok és nem téveszt a gépem.

Előzmény: Windrad, 2019-06-18 08:27:14 [17436]


Windrad | 194    2019-06-18 08:27:14 [17436]

Ha a motorvezérlő bekötésére gondolsz akkor igen. A negatív pólus közös

Előzmény: tibs, 2019-06-18 07:18:12 [17435]


tibs | 118    2019-06-18 07:18:12 [17435]

Ugye az X Y Z egység össze van kötve egy földelő kábellel egyen potenciálra?


Windrad | 194    2019-06-16 20:53:06 [17434]

A 41884 -nél megtaláltam amiről írtál. A motorjaim teljesen újak ezekben még nem lehet elgyengülve a mágnes. Viszont a vezérlő cseréje opció fennálhat, ha később is előjönne a hiba. Úgy tűnik megoldódott a probléma a Motortuning beállításainál felemelt Stepp /Dir pulse értékekkek és az előtolás és gyorsulás csökkentésével. Ma délután is teszteket végeztem, nem jött elő lépésvesztés egyik tengelyen sem. Remélem a továbbiakba sem fog. Köszönöm mindenkinek a hozzászólásokat és a segítséget

Előzmény: Miki2, 2019-06-16 17:12:09 [17432]


B.Zoltán | 1138    2019-06-16 20:45:53 [17433]

Kösz, mérete teljesem megegyezik.
Az enyémnek 0,65ohm 3,2mH csak ennyi a különbség köztük.

Előzmény: Windrad, 2019-06-16 06:23:30 [17428]


Miki2 | 1932    2019-06-16 17:12:09 [17432]

Szervusz!
Mielőtt bármit kezdel, olvasd el a
Segítség Béna Vagyok topikban a 41844 bejegyzést és az arra adott válaszokat.
Én minden eshetőséget végig próbáltam, végül a motor és vezérlő együttes cseréje oldotta meg a problémát.

Előzmény: Windrad, 2019-06-16 11:45:39 [17431]


Windrad | 194    2019-06-16 11:45:39 [17431]

Famegmunkáláshoz javasolták a 10-es menetemelkedésű orsót ,de belátom az 5-ös bőven megfelelt volna. A motorok tápja stabilan adja a 36 Volt feszültséget. Beállítottam a motorhoz passzoló 3,5 A áramot,de sajnos a lépésvesztés ezáltal nem szünt meg . A motorok 4 kábelkivezetésűek a bekötésükkel nincsen semmi gond. A beállításoknál a STEP Low Activ ki van pipálva. Próbáltam ezen változtatni de úgy el sem indulnak a motorok még akadozva sem, ezért visszaraktam a pipákat. A serline mód bekapcsolásával semilyen látványos válltozást nem tapasztaltam. Viszont a STEP/Dir Pulse értékek 5-re növelésével és az álltalad javasolt előtolási sebesség csökkentésével a tesztek során most nem tapasztalok lépésvesztést (Még további próbák is kellenek)
Azt nem értem hogy eddigi munkáim során minden működött rendesen a korábbi beállításokkal (lemartam az asztalt. 56 db lyukat kimartam 2 cm mélységben, Műanyagból is kivágtam 4-5 alkatrészt) És egyszer csak elkezdett lépést veszíteni.
Nem értem hogy ennek mi lehet az oka. Jelenleg az Y tengelyen most is zajosabb a motor mint a többi tengelyen,de ezt a 10-es menetemelkedésnek és az áttétel hiányának tudom be.
A kernelsebesség mennyire lehet hatással a lépésvesztésre? Gondolkodom rajta hogy azt is visszaállítom 25000Hz-re. A Step/Dir Pulse értékeknek mindig azonosnak kell lenniük ,vagy lehet eltérő is? írtad hogy max 20-ig növelhetem az értéküket
A lépésvesztéssel kapcsolatba felmerült bennem az is hogy a Mach3 program futásával együtt a VERTIC-et is futtattam a háttérben. Nem lehet hogy esetleg ez fogta le a PC-t a lépésvesztés pillanatában (A korábbi munkáknál is mindig ment) Próbáltam lefuttatni az adott G kódot felemelt Z tengellyel maróorsó bekapcsolása nélkül, de így is látványosan belassult az Y tengely és rángatni kezdett lépésvesztéskor. Ígyaz elektromos zajt is kizárnám , jók a földelések és megoldott a zavarszűrés is.

Előzmény: Robsy, 2019-06-16 07:05:54 [17429]


Robsy | 1034    2019-06-16 07:09:49 [17430]

A 80 mm/s2 gyorsulást pedig ha már az előzőek hatására megjavult a géped, emelheted fokozatosan a duplájára is.

Előzmény: Robsy, 2019-06-16 07:05:54 [17429]


Robsy | 1034    2019-06-16 07:05:54 [17429]

Sajnos pont a legnagyobb tömeget mozgató Y tengelynél van 10 mm-es menetemelkedésű orsód. Itt vedd vissza a tengelyed maximális sebességét 2200 mm/min körülire. X, Z esetén is picit csökkentsed (1000 körülire a sebességet).
Ha a pulse with értékeket és a motor áramot is még maximálizálod (ahogy már írtam), akkor a lépésvesztésnek meg kell szűnnie.

Még két fontos dolog:
1. A motorhajtások tápegysége 35-40 V-os legyen.
2. Ha 8 kivezetéses a motorod, párhuzamosan kössed be a tekercseit. Amit linkeltél, ott 4 kivezetéses, így akkor ezzel nincs dolgod.

Előzmény: Windrad, 2019-06-15 13:08:03 [17425]


Windrad | 194    2019-06-16 06:23:30 [17428]

Az eredeti vásárlás linkét nem találom, de ez isugyanaz

Előzmény: B.Zoltán, 2019-06-16 00:17:21 [17427]


B.Zoltán | 1138    2019-06-16 00:17:21 [17427]

Milyen típusú a léptetőmotorod?
Úgy néz ki mint, ami az esztergámat hajtja SY60STH86-3008BF.

Előzmény: Windrad, 2019-06-15 13:12:33 [17426]


Windrad | 194    2019-06-15 13:12:33 [17426]

Csatolok pár képet róla

      


Windrad | 194    2019-06-15 13:08:03 [17425]

HY JK02 M5 vezérlőt használok HI DIV268N 5A motormeghajtóval. Elég kevés a manual-jában a beállításokról az infó User manual Itteni képen , nulla érték szerepel a Step /dir pulse Us beállításnál. A hajtás direktben történik ,nincs áttételezés.
X és Z tengelyen 5mm menetemelkedésű golyósorsó, Y-on 10-es a menetemelkedés.
1/8 mikroléptetés beállítása mellett az X=320 Z=320 Y=160 step A hasznos monkaterületem 600 x680x150. A saccolt súly amit hordoznak a tengelyek X=20kg Z=7kg Y=40-50kg. kernelsebesség :35000hz A jelenlegi beállításom a motortuningban. X előtolás 2400 Gyorsulás 70
Y előtolás 3000 gyorsulás 80
Z előtolás 1200 gyorsulás 80
Proóbáltam kisebb előtolási és nagyobb gyorsulási értékeket is, de úgy tűnik ezekkel az értékekkel jól mennek a motorok. A motoráramot fel fogom emelni 4 amperig ami passzol a motorokhoz ,lehetséges hogy itt van a hiba. Próbálkozzak esetleg a Serline mód bekapcsolásával?


Robsy | 1034    2019-06-15 11:40:06 [17424]

Léptető motornál a direkt hajtás választás ideális is lehet, persze ehhez tudni kellene még más adatokat is a már kérdezetteken kívül.

Előzmény: farkastibor, 2019-06-15 10:22:05 [17423]


farkastibor | 457    2019-06-15 10:22:05 [17423]

Fogadjunk hogy direktben (áttétel nélkül) vannak, meghajtva a tengelyek !

Előzmény: Robsy, 2019-06-15 08:34:02 [17422]


Robsy | 1034    2019-06-15 08:34:02 [17422]

Az még lemaradt az előzőekből, hogy mekkora tömegeket mozgat az X, Y, Z tengelyed, és milyen nagyságú maximális munkatérben?

Előzmény: Robsy, 2019-06-15 07:46:45 [17421]


Robsy | 1034    2019-06-15 07:46:45 [17421]

A step pulse adatnak a maximumot(5 ...20) adjad meg.
A motor áramot pedig a gyári adatig növeld meg.

Aztán persze nem ártott volna egy kis hajtás dinamikai optimalizálás se, amikor is a mximális gyorsulási képességre méretezted volna a tengelyeidet. Egy motor fordulatra egyébként most mekkora az elmozdulás X, Y, Z esetén?

Előzmény: Windrad, 2019-06-14 21:12:02 [17420]

Windrad | 194    2019-06-14 21:12:02 [17420]

Újra egy kis segítségért fordulok hozzátok. Az első tesztek a marógépemen 10 mm vastag műanyagba (profilmarás) 1-2 élű maróval, 2db 6-os maró eltörése után elég jóll sikerültek. 3mm maróval viszonylag jól eltaláltam a helyes beállítási értékeket. Náhány marás után viszont azt vettem észre hogy lépésvesztés történik kicsit X-en és nagyon Y-on 2-3 mm eltolódás is van a szerszámpályákon. Az első munkadarabokon nem volt lépésvesztés. első lépésként meghúztam a kuplungok csavarjait majd a motortuning beállításoknál tesztelgettem a gyorsulás/előtolás értékeket, Úgy tünik hogy jók a beállításaim... Kérdésem a következő lenne. Milyen metódust javasolnátok a legmegfelelőbb értékek megkereséséhez?
A Motortuning beállításoknál nem igazán tudom hogy a Stepp/dir pulse 1-5 us-hez milyen értéket írjak. A további kérdésem az lenne hoggy a NEMA 24 (3,1Nm) 4 Amperos motorjaimhoz a DIP kapcsolókkal csak kezdésnek 2Ampert adok 36 Volt feszültséggel..Ez lehet -e a lépésvesztés oka? A motorok nagyon jól simán erőlködés nélkül futnak nem melegszenek nagy előtolási megmunkálásnál sem, Ezért hagytam meg az egyébként nem megfelelő értékeket. Akinek van benne tapasztalata adhatna hozzá némi infót


Ata1 | 320    2019-06-02 19:22:17 [17419]

Köszönöm a segítségeket!

Előzmény: Rabb Ferenc, 2019-06-02 18:22:52 [17412]


PSoft | 13627    2019-06-02 19:19:11 [17418]

Hülye 3D nyomtató...megkevert!
No de annak meg, semmi köze a Mach3-hoz, úgyhogy...ezt is töröljük!

Előzmény: Rabb Ferenc, 2019-06-02 19:11:36 [17417]


Rabb Ferenc | 3390    2019-06-02 19:11:36 [17417]

Az első beírásom is jó volt, de meghajoltam nagyságod előtt. Nem kellett volna ennyire...

Töröljük a hibásakat. Szóval Z-Y-X az igazi!!!

Delete ez és a feleslegesek!

Előzmény: PSoft, 2019-06-02 18:59:29 [17416]


PSoft | 13627    2019-06-02 18:59:29 [17416]

Másodszor már...nem javítalak ki.

Előzmény: Rabb Ferenc, 2019-06-02 18:54:27 [17415]


Rabb Ferenc | 3390    2019-06-02 18:54:27 [17415]

Vagyis igazad van (már megint) a tényleges sorrend Z-Y-X

Előzmény: Rabb Ferenc, 2019-06-02 18:52:24 [17414]


Rabb Ferenc | 3390    2019-06-02 18:52:24 [17414]

Az nagy hiba lenne ha leengedett főorsóval/szerszámmal kezdene el kolbászolni a másik két tengely...

Előzmény: PSoft, 2019-06-02 18:46:52 [17413]


PSoft | 13627    2019-06-02 18:46:52 [17413]

Lehet rosszul emlékszem, de all home esetén nem a "Z" tengely veszi fel utolsónak a pozíciót?

Előzmény: Rabb Ferenc, 2019-06-02 18:22:52 [17412]


Rabb Ferenc | 3390    2019-06-02 18:22:52 [17412]

Minden tengelynek kell egy végállás kapcsoló. Ezeknek a jelét tengelyenként azonos pin-re irányítod a Config - Port and Pins - Input Signals fülön és bepipálod az X-- és X Home stb stb ablakokat.

Ezek után ha megnyomod a billentyűzet HOME gombját vagy ráklikkelsz a képernyőn a REF ALL HOME területre, minden tengely teszi a dolgát. Z-Y-X sorrendben elindulnak a nullpont felé (ha rossz irányba indulna valamelyik, az Motor Home - Soft Limits ablakban megfordíthatod az irányát) Ugyanitt állíthatod ben a HOME-ra futás sebességér a max sebesség százalékában (Speed %) Ez ne legyen több 20-30%-nál mert akkor lehet, hogy nem tud időben megállni. Szintén ugyanitt adhatod meg a lassítási út hosszát (Slow Zone) kikísérletezve a biztonságos értéket.

Ha a Home kapcsolóra ráfutott a tengely az megáll és visszalép annyira,hogy lefusson a kapcsolóról. Ezután már ez a kapcsoló végállásként funkcionál, vagyis X--; Y--; Z--.

A tényleges mozgáshatárokat a Soft Min és Soft Max értékekkel tudod beállítani. Persze a főképernyőn a Soft Limits gombot aktiválni kell (zöld keret)

Előzmény: Ata1, 2019-06-02 12:22:35 [17410]


Windrad | 194    2019-06-02 15:13:18 [17411]

Célszerű minden tengelyen kettő darab végálláskapcsolót használni és ebből valamelyiket kinevezni egyben hóming kapcsolónak is.Így elég 3 bemenet a végállásokhoz és a hominghoz. Referencia pont felvételekor nem működik a Hard limit funkció , majd a homing befejeztével a kapcsolók újra végálláskapcsolóként működhetnek. Vedd a Z+ és Z- kapcsolókat egy bemenetre a vezérlődön X+ és X+ kapcsolókat egy bemenetre, Y+ és Y- kapcsolókat egy bemenetre. A Mach3/config/Port and Pins/Input Signals-ban Beállítod X+, X-, X Home, Mindegyikhez: Port:1 Pin : (a vezérlődön a X+X- vezetékek által használt PIN száma) Legyen mindegyik Enable.Azt hogy AKTIV Low vagy High az Automated Setup segít eldönteni. Emulatednél legyen :X. Ez összes tengely kapcsolóit állítsd be ugyanígy. Ezután Config/homing-limits/ Ha a Home Neg-hez pipát teszel akkor a negatív irányba keresi a Home kapcsolót. Ha az x-et otthagyod akkor pozitiv irányba fogja keresni a Home kapcsolót. Auto zero is legyen kipipálva. Ebben az ablakban tudog beállítani a soft limitet is

Előzmény: Ata1, 2019-06-02 12:22:35 [17410]


Ata1 | 320    2019-06-02 12:22:35 [17410]

Köszönöm!
De még kellene valami okosság.
Elindul az érzékelő felé de nem állítja meg.
Próbáltam többféle beállítással,de nem akar megállni a kapcsolónál csak akkor ha végállás kapcsolónak használom.
Hol ronthatom el?

Előzmény: TBS-TEAM, 2019-05-31 23:25:12 [17409]


TBS-TEAM | 68    2019-05-31 23:25:12 [17409]

http://www.sasovits.hu/cnc/doc/Mach3HU_1_1.pdf

27 oldal.

Előzmény: Ata1, 2019-05-31 20:37:21 [17408]


Ata1 | 320    2019-05-31 20:37:21 [17408]

Sziasztok!
Referencia kapcsoló beállításához szeretnék segítséget kérni.
Induktív érzékelőt szereltem fel a gépre,referencia pontnak vagy fix null pontnak szeretném használni.
Hogy és hol tudom beállítani hogy elmenjenek a kapcsolóig a tengelyek.
Ha X-- ra állítottam végállásként működtek, de X home kapcsolóval nem boldogultam.
Hogy lehet beállítani hogy elinduljon a kapcsolók felé?

Segítséget előre is köszi.
Attila


noctiluxx | 97    2019-05-30 15:19:39 [17407]

Igenigenigen, bár az utolsót - gondolván univerzális info - kb mindenkinek címeztem

Előzmény: Franczy, 2019-05-30 13:37:49 [17406]


Franczy | 5013    2019-05-30 13:37:49 [17406]

A "Válasz erre" gombot használjad, hogy más is lássa kinek írod amit írsz!

Előzmény: noctiluxx, 2019-05-30 10:31:15 [17405]


  Fórum főoldal  |  A lap tetejére

Időrend:
Oldal 2 / 348 Ugrás ide:
Sorok:
|◄ Első  ◄ Előző   1  2  3  4  5  6   Következő ►  Utolsó ►|


 ◊